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TOPICS

œ CFBuilder: the free extension for the free VSCode editor
œ We’ll cover briefly…some common initial questions
œ Installation (including on vscodium)

œ Features and benefits
œ VSCode features
œ CFB basic features
œ CFB configurability; features which require additional configuration (in CFB and/or CF)

œ Comparison to other VSCode CFML extensions and to traditional CFML editors
œ What they offer that CFBuilder does not; what CFBuilder offers that they do not

œ Some more on CFB and VSCode
œ Resources for finding more on both
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ME.ABOUT()

œ I focus on CF server troubleshooting, as an independent consultant
œ Assist organizations of all sizes, experience levels

œ Work remotely 99% of the time, safe, secure, easy (via shared desktop)

œ Solve most problems in less than an hour, teaching you also as we go

œ Satisfaction guaranteed
œ More on rates, approach, online calendar, etc at carehart.org/consulting

œ But to be clear, I’m not selling anything in this session! 

œ Again, slides for this talk available online:
œ carehart.org/presentations
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AUDIENCES

œ There are many different potential audiences for this talk:
œ Those who love CFB and look forward to learning more

œ Those who’ve heard of CFB on VSCode and want to learn more

œ Those who knew of old Eclipse CFB version, unaware of VSCode extension

œ Those who have never heard of CFBuilder, either variant

œ Those who’ve never heard of VSCode

œ Those who use VSCode or CFB, as “a text editor” and expect nothing more

œ Those who get frustrated with not finding things familiar in other editors

œ Those who’ve tried CFB on VSCode and hit problems

œ Those using only other VSCode CFML extensions, who feel any of the above
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CFBUILDER: THE FREE ADOBE EXTENSION FOR 
THE FREE MS VISUAL STUDIO CODE EDITOR

œ Before we go any further, let’s make a few points clear

œ VSCode is free, open source, from Microsoft
œ Formally “Visual Studio Code”, aka simply “code” (NOT Visual Studio)

œ Has huge marketplace of free extensions from the community and vendors

œ By some estimates, VSCode is by most developers across most languages

œ CFBuilder (aka “CFB”) is free, closed source, from Adobe
œ Extension first released in July 2022; a few updates since then

œ Original CFBuilder was commercial and closed source, based on Eclipse
œ Last updated with CF2018, retired in 2024

œ CFB for VSCode available for Windows, MacOS, Linux
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SOME COMMON INITIAL QUESTIONS

œ What’s the relationship of VS Code to MS Visual Studio?

œ Why did Adobe choose to leverage VSCode?

œ What about existing CFML extensions for VSCode?

œ What if I have problems with xxxx? (Covered later)
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INSTALLING VSCODE & CFBUILDER

œ Two key resources
œ VSCode: code.visualstudio.com/docs/setup/setup-overview
œ CFB: helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-

code/get-started-coldfusion-builder-extension-visual-studio-code.html

œ Some folks prefer VSCodium (“codium”) over VSCode from MS
œ CAN use CFB with it! More on this later

œ CFB’s design requires Java be installed & JAVA_HOME env var defined
œ More on this later

œ Both tools install easily, can start working with them within seconds (even now)
œ But with both, there’s much you can learn to be more productive, as we will see!

œ Demo: let’s see those install docs, open it briefly for those who’ve never seen it
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FEATURES AND BENEFITS
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VSCODE FEATURES

œ So many: code formatting, code folding, terminal, word wrap themes …
œ File comparison, timeline, git integration, emmet expansion for html/css/more, AI, more…

œ Could do literally for multiple talks on these alone
œ I’ll point out at end resources for these and many more VSCode capabilities

œ Most available via either menus, buttons, keyboard shortcuts (configurable), or…

œ Perhaps most important VSCode tip: USE THE PALETTE!
œ Access with View>Command Palette menu or ctrl-shift-p (or more simply F1) keystroke

œ Start typing, to access world of feature possibilities

œ Note that it remembers the most recently used ones at the top
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CFB BASIC FEATURES

œ IntelliSense/Code assist 
œ Cfml tags, functions, script statements appear as you start typing their name

œ Can hit enter to select before completion (or use arrows to select)

œ Hit space on tag to see popup description and attributes of tags, ctrl-space to see 
values

œ Tag completion (closing tag offered after ending opening tag, where appropriate)

œ Syntax help: mouse over a tag to see more help, and link to CF docs

œ And still more …
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CFB BASIC FEATURES (CONT.)

œ As well as: 
œ Color coding

œ Code formatting (that recognizes CFML, cfscript)

œ Hover help

œ Code navigation/outlining/folding

œ Code insertion/wrapping (comments, dump, abort, as tags or script), #s, more

œ Also supports these features for HTML, JavaScript, CSS

œ And there are still more powerful features. More on them in a moment

œ But what if you don’t like the choices Adobe made? …
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CONFIGURABILITY OF CFB

œ On a CFM page, click “Profile Preferences” in lower right (or use palette: Profile 
Preferences)
œ Can control tag closing, auto-quoting, indentation, white space insertion, wrapping, 

braces, and more

œ Also offers profiles to save grouped settings

œ Still a few other settings for the CFB extension: 
œ Click Extensions in sidebar, right-click installed ColdFusion Builder extension 

œ choose “settings” (also available by left-click of gear icon shown for extension)

œ (Or use palette> @ext:com-adobe-coldfusion.adobe-cfml-lsp)

œ …
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CONFIGURABILITY OF CFB (CONT.)

œ Can also modify/view keyboard shortcuts for CFB features
œ Use steps above but choose “keyboard shortcuts” instead of “settings” (for CFB)

œ Shown over 80 CFB features/commands and their shortcuts 
œ About 1/3 have shortcuts assigned: can change/remove

œ Can add shortcuts to any of the rest

œ Can also configure the shortcuts for hundreds of VSCode feature 
œ (remove the search value shown at top, @ext:com-adobe-coldfusion.adobe-cfml-lsp)

œ More on configurability of VSCode, later

œ Several powerful CFB features require more than just “opening a CFM file”…
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CFB FEATURES THAT REQUIRE 
ADDITIONAL CONFIGURATION

œ These include:
œ Code refactoring, “quick fix” capabilities
œ Security code analysis (identifies  code vulns in CFML, proposes fixes)
œ Code profiler (in association with CF PMT)
œ Step debugging
œ Server management
œ RDS: Remote access for code, datasources, and more
œ SQL building, editor
œ Log viewer
œ Services browser

œ If this was a daylong workshop I’d demonstrate each, showing their power
œ Again, other resources do that, which I offer in this talk

œ Key: these need info in your CF server admin config, or the relationship of files (as “project”)…
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DEFINING A WORKSPACE, PROJECT

œ Define a “project” holding your CF code, which requires first a “workspace”
œ Workspace can technically be anywhere, just a folder where a file of metadata is put

œ Project is the actual location of your CFML code
œ That code can be anywhere, need NOT be in cf’s “wwwroot”

œ But some features will only work if it’s a folder accessible by some URL in your browser

œ helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-
code/project-manager.html

œ Note that a coming update will remove requirement of a workspace!

œ Then some features require also rely on defining connection to a CF “server”…
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DEFINING A “SERVER”

œ Under CF logo, configure a CF “server”, pointing to your CF instance
œ Defining access to CF instance, local or remote (domain/ip, port, RDS password)

œ If remote, your CFB machine must be able to reach that port of course

œ helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-
code/add-coldfusion-builder-vscode-extension.html (that’s not a mistaken URL)

œ Notice how this enables the RDS File View and RDS Dataview features

œ Also empowers features where CFB needs CF config like datasources, 
mappings, etc.
œ These are what require that the “project” be connected to a “server”

œ Step debugging and security analyzer also require connection of “project” to 
“server”



Charlie Arehart, CArehart.org
@carehart

DEFINING A “SERVER” (CONT.)

œ When pointing to Commandbox instance, may get “invalid server home” error 
œ See my solution(s):

œ community.ortussolutions.com/t/commandbox-visual-studio-code-adobe-coldfusion-
builder-extension-with-commandbox/9376/5 
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COMPARISON TO OTHER VSCODE 
CFML EXTENSIONS
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FAMILY TREE TIME:
SOME NEW, MOST ORPHANED

œ Newer/currently updated
œ CFMLEditor (cfmleditor.cfmleditor), from Gareth Eddies, forked from KamasamaK (below)

œ Boxlang (ortus-solutions.vscode-boxlang), for boxlang (with cfml support as forked from Vadim below)
œ Included also within BoxLang Developer Pack (ortus-solutions.vscode-boxlang-developer-pack)

œ Older/orphaned/no longer updated
œ Vscode-cfml, from Vadim Sibiryanskiy, last updated in 2023, which was a fork of…

œ Vscode-cfml, aka “CFML”, “Kamasamak” (kamasamak.vscode-cfml), last updated 2022, adapted from:
œ vscode-coldfusion , aka “ColdFusion” (ilich8086.coldfusion), from Ilya Verbitskiy, last updated 2018

œ ColdFusion, aka “Sketchpunk” (sketchpunk.coldfusion), last updated in 2015

œ And more (note some are Lucee-only, like “CFML Formatter”)

œ Beware judging them by “Install Count”, older ones naturally have larger values
œ Note that VSCode default sort order is an undefined algorithm: not install count, rating, update date



Charlie Arehart, CArehart.org
@carehart

WHAT DID/DO OTHERS OFFER FOR CFML?

œ Considering all those built from kamasamak, ilya, vadim, etc.
œ Things they offer (which CFB does as well)

œ Color coding, code formatting, hover help, code assist, snippets
œ Ample (different) configurability of these things 

œ Things they offer which CFB does not
œ Linting (static code analysis, enforcing coding standards)

œ Bundling CFLint extension (KamasamaK.vscode-cflint), which can be added to CFB

œ Don’t require java like CFB, nor use of project or workspace like CFB does for some features
œ And for many people, the above may seem “enough” to code CFML on VSCode

œ Things CFB offers that they do not
œ Recall those 10 features listed previously, which rely on defining a project, perhaps server
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WHAT ABOUT OTHER TRADITIONAL CFML 
EDITORS?

œ I realize some have long stuck with older CFML editors
œ DW: support for CF (and ASP, JSP) dropped in 2013, never updated for newer CFML

œ CF Studio (dropped in 2001), HomeSite+ dropped in 2009

œ Many still favor Notepad++, Sublime Text, others
œ CFML support for them ended (2011 and 2012, respectively)

œ Still, folks love how they open fast, are straightforward
œ Still, each has their own ways of doing things (keystroke, Uis, snippets, etc.)

œ Note that there are VSCode extensions to ease NP++, Sublime transition
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WHAT ABOUT…?

œ Snippets?
œ File>Preferences>Configure Snippets

œ Select “cfml.json”, see comments in the file for how to configure your own snippets

œ Insert them using Command Palette: Snippets: Insert Snippets

œ FTP?
œ CFB offers no features for that, but extensions exist (consider SFTP, SSH, RDS)

œ Wysiwyg html editing?
œ VSCode does not offer that natively

œ Configuring quick-access buttons?
œ CFBuilder enables several actions on top right, not configurable it seems
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MORE ON CFB AND VSCODE
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SOME FREQUENT CFB/VSCODE 
CHALLENGES

œ Error: “Java version greater than 7 is required to run CFML extension"
œ Must set JAVA_HOME env var
œ helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-code/get-

started-coldfusion-builder-extension-visual-studio-code.html#install
œ Again, some features won’t work unless CFB “project” is defined, others need “server”
œ VSCode “Restricted mode”

œ If you open a folder that VSCode does not yet recognize, it will be in “restricted mode”
œ CFB features won’t work because all extensions will be enabled or limited
œ Can choose to “trust” (the authors of) the folder in question or its parent

œ Other extensions may cause conflict
œ Can “disable” for all of VSCode, or a specific workspace (no need to “uninstall”)

œ …
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SOME FREQUENT CHALLENGES (CONT.)

œ CFB sometimes forgets/does not preserve display of projects
œ Only affects features that require that be configured, can “import” project definition

œ CAN disable VSCode features that may annoy you:
œ “sticky scroll”: right-click when it appears, to disable

œ “minimap” (on right): right-click and select “minimap” (to disable)

œ AI/copilot feature popups: Settings (ctrl+,) then search for disableai

œ Beware: if you open a different folder (file>open folder), will be prompted to save 
unsaved tabs
œ Doesn’t happen if you open just a file

œ What if you don’t want to lose tabs? Can instead open a new window…
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SOME MORE VSCODE TIPS

œ You can open a new window: File>New Window; then File>Open Folder
œ Also, if that folder has no extensions associated with it yet, can choose to enable any

œ Allows you to try different extensions (no need to “uninstall” one you don’t want)

œ Can also open new window with new “profile” (giving it a name), and enable 
only some extensions

œ Note when viewing files in file explorer (top left icon in VSCode):
œ If you single-click a file, it opens in a tab but does not STAY open if you click another

œ If you double-click a file, it opens in a tab and stays open until you close it

œ Like many modern editors, can close without saving text. Still there on re-open

œ …
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SOME MORE VSCODE TIPS (CONT.)

œ Can choose to sync VSCode settings across machines (via log in)

œ Can opt out of VSCode collection of telemetry/usage data
œ Use Settings (ctrl+,), search for telemetry

œ Can enable emmet text expansion for html, css, js
œ To enable that within CFML files, add to vscode settings.json:

 "emmet.includeLanguages": {
  "cfml": "html"
 }

œ And again really so much more I COULD point out
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IMPLEMENTING CFB IN VSCODIUM

œ Finally, some are adamantly against MS licensing, not wanting MS telemetry, etc.

œ VSCodium (vscodium.com) is built from same VSCode open source
œ But no MS license (is permissive MIT license instead)

œ No MS branding; lacking some MS-provided features

œ And no MS Telemetry
œ Again: MS Telemetry can easily be DISABLED in VSCode (as we saw)

œ While VSCodium uses its own marketplace (open-vsx.org), CFB not offered there

œ But you CAN implement easily CFB within VSCodium…
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IMPLEMENTING CFB IN VSCODIUM 
(CONT.)

œ You would use the VSCode feature to install an extension via its “vsix” file

œ You can no longer obtain those from VSCode marketplace, but can either:
œ Install CFB on VSCode and use “download vsix” under gear on all extension pages

œ Downloading the extension at vsixhub.com/vsix/96583/

œ Then in VSCodium, use “install from VSIX”, either:
œ From Extensions tab, under its “…” (actions), choose “install from VSIX”

œ Using Palette, type “install from VSIX”

œ Point to the vsix downloaded above, then it’s installed instantly just like on VSCode

œ Everything we’ve talked about will work the same in VSCodium as in VSCode
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RESOLVING PROBLEMS

œ Consider VSCode, CFB logs
œ Open Palette (F1), then type Developer: Open Extension Logs Folder

œ There have been 4 CFB updates (in 2025, 2024, and 2023)

œ Can log bugs, feature requests in tracker.adobe.com
œ select “ColdFusion Builder Extension for VSCode” as product

œ Currently only 17 filed (just 5 from 2025); 11 marked “to fix”

œ Seek help from community: cf411.com/cfsocialhelp

œ Can email Adobe: cfsup@adobe.com

œ Reach out to me directly, will help where I can (free or perhaps as consulting)
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WHAT IF YOU’RE STILL NOT SOLD ON CFB?

œ I get it: some are happy with the CFML extension they use
œ Or they’ve tried CFB and hit problems, and may still not be motivated to seek solution

œ Maybe you just prefer older editors, whether they support CFML or not
œ I’ll just note that you could just as readily use VSCode to edit CFML without CFB, etc.

œ Even for both audiences, consider that you could STILL use CFB
œ Such as to perform the CF Code Security Analyzer feature

œ Or perhaps the PMT profiler feature, or even the CFML step debugger feature, etc.
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FINDING MORE INFO ON CFB

œ See front page when extension is selected, offers reminders, doc links, or see:
œ helpx.adobe.com/coldfusion/cfb-extension-vs-code-plugin-user-guide.html

œ Many sections/docs below that (expand left nav bar). Let’s visit…

œ Beware search engines/Ais/posts pointing to docs for OLD CFBuilder…
œ Not:

œ helpx.adobe.com/coldfusion/using-coldfusion-builder/managing-projects.html

œ But:
œ helpx.adobe.com/coldfusion/coldfusion-builder-extension-for-visual-studio-code/project-

manager.html
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FINDING MORE INFO VSCODE

œ Help>Open Walkthrough (also offers videos)

œ Help>Editor Playground (guides)

œ Help>Documentation (code.visualstudio.com/docs)

œ Help>Keyboard Shortcuts Reference

œ code.visualstudio.com/docs/getstarted/introvideos

œ code.visualstudio.com/docs/getstarted/getting-started

œ code.visualstudio.com/docs/getstarted/tips-and-tricks

œ Many community resources: blog posts, videos, courses (LinkedinLearning, 
Udemy, etc.)
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FINALLY…

œ I’ll add that I am contemplating creating an online course
œ Send email to support@carehart.org, subject “course”, if interested to be notified

œ As time remains, some quick demos
œ VSCode:

œ Ctrl+shift-F: find text in all files of currently opened folder or open tabs
œ Option: show results as tree
œ Option: search only open files/editors, not current folder

œ “quick search”: similar but opens scrollable popup list of results
œ Ctrl+R : search files/folders by name (any part), from recently opened ones
œ Opening folder in new window (without needing to close editors/tabs NOT in that folder)
œ Timeline (especially if not using source control)
œ Integrating alternative compare tools (whether using source control or not)

œ …
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QUICK DEMOS (CONT.)

œ As time remains, some more quick demos
œ CFBuilder:

œ Code security analyzer

œ Step debugger

œ Code profiler (PMT integration)
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SUMMARY

œ CFB is more than just Adobe’s extension: also all of VSCode (and its abilities)
œ CFB adds many features that other CFML extensions don’t support (for better or worse)

œ Ample resources exist to learn more about both CFB and VSCode
œ Many concerns/complaints have been/can be resolved, or can reach out to Adobe

œ Again, my contact info for follow-up:
œ Charlie Arehart

œ charlie@carehart.org

œ @carehart (Slack, Github, X, FB, LinkedIn, etc.)

œ Slides: carehart.org/presentations

œ With that, hope you enjoyed the talk! 
œ Use QR code for slide deck

œ ...time for questions?
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