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Rather than do slides, I offered these notes with ample detail

- While I hope to share all the tips you need, including some odd scenarios, some

will still struggle 

     - There is rather scant discussion of setting up debugging in the CFBuilder and

CF docs
     - You can certainly seek help on the CFBuilder support forums, but many seem to struggle

getting help there

     - I am available to help on a consultative basis (carehart.org/consulting)

          - not saying that to sell myself, nor is this talk a sales pitch, but I want you to know you can

get help and need not give up if you struggle

- CFBuilder can debug CF 8 or CF 9 only

     - CF 7 and below cannot be debugged using the built-in debugging in CFBuilder 

     - You can technically do debugging with Eclipse without CFBuilder

           - using the older Adobe ColdFusion 8 Eclipse Extensions. See my previous talk on

that: http://www.carehart.org/presentations/#cf8debug    
     - You can also debug CF 6, 7, 8, or 9 using the commercial alternative, FusionDebug. More at

fusiondebug.com and http://www.carehart.org/presentations/#fusiondebug  

     - Discussing the older Eclipse Extensions and FusionDebug are both beyond the scope of this

talk

- You can debug a local machine or a remote machine

     - referring here to the location of the server to be debugged relative to the location of the

debugging client (CFBuilder) 

     - The steps here work for either and will highlight any important differences

- You must be able to connect  to the CF Admin on the machine to be debugged, from the machine

running the debugging client

     - HERE IS WHERE MOST HAVE PROBLEMS or confusion, when they try to

configure RDS support (coming in next step)
          - before even beginning to talk about setting up the server or CFBuilder for debugging, this

must be covered and resolved first!

     - the RDS connection will be done over http, just like the CF Admin

          - you will need to use the SAME hostname and port as you would use to run the CF

Administrator on the server to be debugged, as if you launched it from the machine running

CFBuilder

          - therefore you will need to know (and confirm you can access) the URL for the CF Admin of

the server (instance) to be debugged, from the machine running CFBuilder

               - launch the Admin from the machine running CFBuilder. 

                    - Don't trust your memory or what may have worked in launching the Admin on the

machine running CF (if it's different from localhost)

                         - if it's for an instance within a multiserver configuration, confirm inside the CF

Admin that you have indeed used the right URL to access the instance you intend to access 



                    - If it works, note the domain (or IP address) and port for the next step in configuring

RDS support in CFBuilder

                    - if it doesn't work, there may be any number of explanations  

               - note that the CF Admin (and therefore RDS) may not be accessible from the machine

you're trying to do debugging from

                    - the CF Admin may be set to be called using the built-in web server of CF (such as

port 8500, or 8300, 8301, etc.)

                         - it may be possible that the port used for the Admin (and therefore RDS) is

blocked by a server firewall so you cannot access it from outside the machine

                              - if you can't solve that, you cannot do debugging from outside the server. 

                                        - You could launch CFBuilder on the server or within the network that

does have access to the port

                              - you could also arrange to be able to access the CFAdmin (and RDS) using

the external web server (beyond the scope of this presentation) 

          - note that you can connect to CF Admin (and therefore RDS) using SSL, if that's been

configured on the (beyond the scope of this talk)

  

- The CF Server to be debugged against must have RDS enabled

     - TIP: you can test if it's enabled by browsing the domain/IP and port from

above, and adding  /CFIDE/main/ide.cfm

          - as in http://localhost:850/CFIDE/main/ide.cfm

               - again, use the same base URL/port as the CF Admin. This is critical! 

          - if things are working, you will get a status code 405 reporting "HTTP method GET

is not supported by this URL"

               - this is "good". It confirms RDS is responding, but you're making an http get request in

the browser, and that's not supported.. 

                    - CFBuilder will make a post connection instead, which will work

          - if you get a 404/file not found, then RDS is not enabled

      - if not enabled during installation, see Adobe technote for how to enable

it: http://kb2.adobe.com/cps/172/tn_17276.html  

          - be very careful editing this, CF may "start" but be inaccessible

               - se [cf]\runtime\logs or [jrun]\logs to view log file that will point out the problem,

including line of code in XML file where you made an error.

          - also, be aware of the security concerns regarding enabling RDS

               - discussed some in the technote above

               - see my previously mentioned talk on the

subject: http://www.carehart.org/presentations/#rds2  

                    - note as well the new Multi-user RDS support in CF 8/9 Enterprise

                         - see my talk on this at http://www.carehart.org/presentations/#multiuser  

               - not as critical for a local machine, if it's not web accessible

- You must configure an RDS connection to the server

     - can do this in Preferences>Adobe>RDS Configuration

               - or in View>RDS Dataview or View>RDS FileView 

     - provide a description, as well as hostname and port to access the CF

server/instance to be debugged

          - again, these must be THE SAME as you would use to access the CF

Administrator on the server to be debugged, as if you launched that Admin from the

machine running CFBuilder

               - see more in the related discussion above



               - see more in the related discussion above

     - you also need to provide valid RDS username/password

          - if Admin is appropriate username, can leave it blank (or specify Admin)

          - password is that which was requested during CF installation if RDS is

enabled during installation

               - or that provided or changed in the CF Admin Security>RDS page

          - on CF Standard, the only possible username is Admin

               - on Enterprise, default is Admin but administrator could have defined

multiple usernames and even could disable Admin as a user

               - again, see my talk on this at http://www.carehart.org/presentations/#multiuser  

     - you do NOT need to provide the CONTEXT field value, unless running CF as a

WAR/EAR on a JEE server

          - do NOT need it for Server *or* Multiserver (multiple instances)

               - each instance has its own CF Admin and therefore its own port you

would use to access the Admin and therefore to access that instance via RDS

- Testing a new or existing RDS connection

     - while adding an RDS configuration, you can test it against the server 

          - Use the RDS dataview to view RDS connection(s) to server(s)

               - within view, right-click and use  "RDS Configuration". Note available test button

                    - note that there is a timeout value set on the RDS config screen, so some errors

may take that long to appear

               - or you could also just try expanding an existing RDS connection in the view, to see if it

can show datasources within the server 

                    - you can also do such testing of RDS connectivity from within Dreamweaver, CF

Studio, or HomeSite+, if they are more comfortable. Again, see my talk above on (#rds2)

                         - the debugger for CF8 and 9 can only be called from CFBuilder or

Eclipse/CFEclipse

          - possible errors:

               - if RDS is not yet enabled, will get "Unable to contact the RDS Server..." and later

"Status Code: 404, Reason, Not Found"

                         - but this same error is also offered if you provide the wrong port (such as 80,

when the Admin is on the built-in web server port like 8500)

               - if port not exposed (again, using same as CF Admin), will get "Unable to contact the

RDS server..." and later "Connection timed out: connect"

               - if username/password not correct, will get "The RDS server was successfully

contacted, but your security credentials were invalid"

                    - again, default username is Admin., RDS password is that specified in the CF Admin

Security>RDS page  

- The server to be debugged must have CF debugging enabled 

     - Enabled in CF Admin>Debugging & Logging>Debugging Settings page

          - not to be confused with "debug output settings" page 

     - Check the "allow line debugging" checkbox

          - this causes the CF Admin to change the underlying jvm.config to add java debugger

arguments

     - Must restart CF for this to take effect

     - Note that once CF is restarted with debugging enabled, there is also an available button to

interactively start/stop the debugger, if desired 



- You must create a project in CFBuilder

     - creating projects is discussed in the CFBuilder documentation

    - you DO need to configure a "Server" for the project (either at creation of

project, or later via project properties)

          - this also enables many other powerful editing features, as well as internal

browser feature

          - configuration options for adding a new server are discussed in the CF

Builder docs

               - and also at:

                    - http://www.mattgifford.co.uk/coldfusion-builder-server-management/  

                    - http://forta.com/blog/index.cfm/2009/7/13/Getting-Started-With-The-

New-ColdFusion-Builder  
     - the values entered here for server and port are again those for the CF Admin, as discussed

above

          - sadly there is no "test" button in this page, as there was in the RDS setup page

     - you do not need to install the "Extensions" feature (last step of adding a server configuration)

to use debugging

    - if you created a project previously and did not define a server, you can do that from the

project's properties>ColdFusion Server Settings

          - In Servers dropdown, choose "add server" and follow prompts.

               - note that there you can create a new server by defining all details or pointing to an

existing RDS server configuration to import settings 

- You must create a debug configuration in CFBuilder

     - use Run>Debug Configurations. Select "ColdFusion Application". Press the "new launch config"

button (icon in top left of dialogue, above "filter text" field)  

          - again, you will need to point to a "Server" as configured for projects, 

     - with a server configured, you can choose it from the "server" select control

          - again no mechanism to test things

     - can then hit "close" or "debug" to start debugging.

          - for now, just hit close

- You must open the file to be debugged from within a project

- You must set a breakpoint (right-click and toggle breakpoint, or ctrl-shift-b) 

- Tip: Test browsing a page that you want to debug (just open the page in a browser, pointing to

the server where the page is located)

     - you need to be able to browse it on the server where it lives in order to also debug it

          - again, keep in mind the points above about how you needed to be able to access the CF

Admin on the server being debugged. Same applies to pages being browsed/debugged

     - you do NOT need to browse it from within CFBuilder

          - you can indeed also debug pages run in a browser outside of CFBuilder

               -   in fact, any CF page run from any browser (by any user) against the debugged server

will trigger it being debugged

- you must open the debugging perspective

     - Window>Open Perspective>Other>ColdFusion Debugging

- You must start the debugging configuration



     - use Run>Debug Configurations and choose the configuration created above

          - then choose the "debug" button at the bottom

               - once you've done this, you will also see the option to debug using this configuration

using the "bug" icon in the toolbar under the top menu of CFBuilder commands

     - if there are errors at this point, review all the steps above

- You (or someone) must browse the page to be debugged, in order for the debugger to intercept

the request

*Following section  ADDED AFTER PRESENTATION*

- If you're debugging a remote server

     - You will need to have a local copy of the source code (or have a drive mapping pointing to the

remote server's code)

     - During the configuration of the Server (for the project), you will need to specify "isremote" 

          - and the next page in the dialogue will ask you to create "Remote Server Settings"

               - the default for CF servers is to have a naming port value of 2910, and to have

username/password values of admin/admin

                    - you may need to change these fro your server, and especially if you're running

multiple instances or multiple versions of CF at once (8 and 9, for instance)

              - for more on setting up remote server config in CFBuilder, see:

                    - http://blogs.adobe.com/cfbuilder/2009/07/remote_server_setup_is_it_real.html 

     - in addition to worrying about the RDS configuration and firewall issues for accessing the CF

Admin, same is true for a debugging port that is used

          - unfortunately, it is NOT the 5005 value specified in the CF Admin Debugger Settings page

                    - by default, it is NOT exposed to us in any way because Adobe chose to make it

random, to increase security

               - if you want/need to make it a fixed value, you can do that by editing the jvm.config to

specify a new argument: -DDEBUGGER_SERVER_PORT=portNumber

                     - then you would open that port in your firewall, and then CFBuilder could

successfully debug against the server

               - More on this

at http://help.adobe.com/en_US/ColdFusion/9.0/Developing/WSc3ff6d0ea77859461172e0811cbec0d389-

7fff.html

- Also, if need to  edit a CFBuilder Server configuration, note that sadly you cannot do so from

within the Project properties

     - instead, use the Window>Show View>Other>ColdFusion>HTML Standard Views>Servers

          - there you can righ-click any defiend server and use "edit server" to edit its properties

Further details on using the debugger are beyond the scope of this presentation. 

     - See my previous presentation on using CF

debugging: http://www.carehart.org/presentations/#cf8debug  

          - While it was for CF 8 Extensions, things work the same in CFBuilder 

     - See as well my FAQU article that condenses that: http://www.carehart.org/articles/#2008_4 

          - and my chapter on CF debugging in the CF 8 Web App Constr. Kit

               - chapter available online at http://www.carehart.org/articles/#2008_2   

     - the CFB team also did a video on using the

debugger: http://blogs.adobe.com/cfbuilder/2009/07/debugging_in_cfbuilder.html  


