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Not an “Intro to CFBuilder”
• There are many important features I won’t discuss
Still, many many tips to share

No time to detail each of them• No time to detail each of them
• Will often point to URL with more info
Presentation PDF posted at p
carehart.org/presentations



May include those new to/expert in Eclipse
M b i f CFE li• May be coming from CFEclipse

May never have gotten into it, or tried and passed on it
• May be coming from 

Dreamweaver/HomeSite+/CFStudio
There are some things that address each 
groupgroup
• And there are some that fail to satisfy each group
Be patient with this talk

Y l d k f h hi• You may already know some of these things
• You may even think of things I didn’t share
• Feedback welcome, as always



Hidden Gems in Working with Files
dd G dHidden Gems in Editing

Hidden Gems in Configuring the IDE
Hidden Gems in TroubleshootingHidden Gems in Troubleshooting
Hidden Gems in Connecting to CF Servers
Hidden Gems in Editing Code on Remote g
Servers
Miscellaneous Hidden Gems
S G t hSome Gotchas
Resources for Learning More



Independent Consultant

•13 yrs CF experience (27 in Enterprise IT)
Web home at www.carehart.org
•Host ~300 blog entries, 80+ articles, 

•Member, Adobe Community Experts
•Certified Adv CF Developer (4-8), Cert. 

Adobe Instructor
•Frequent speaker to user groups, 

90+ presentations
•UGTV: recordings of 500+ presentations 

by ~250 speakers
•CF411.com – 1,200+ tools/resources in q p g p ,

conferences worldwide
•Run the Online ColdFusion Meetup

(coldfusionmeetup.com)
•Living in Alpharetta Georgia (Atlanta)

, /
125+ categories

•Hosting courtesy of EdgeWeb Hosting
•Consulting: available for CF 

troubleshooting tuning; training•Living in Alpharetta, Georgia (Atlanta) troubleshooting, tuning; training
•Remote or on-site
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Available standalone and as plug-in
• Most features should work the same

But be aware there can be differences
Bundles Aptana Studio (commercial plugin)Bundles Aptana Studio (commercial plugin)
• Many important features come from that
Note that installing own Aptana may conflictg p y
• Also, different base editions of Eclipse can impact
Of course, works with any version of CF



When I refer in talk to CFBuilder Preferences
i ’ i Wi d• it’s in Window>Preferences on Windows

but in Adobe ColdFusion Builder>Preferences on Mac
• I’ll just start with Preferences> to avoid confusion

But note that Window menu option does exist on Mac, 
used for other things, like Window>Show View

And of course, if I say ctrl+click something, , y g,
on Mac that’s command+click

OK ith th tiOK, on with the tips…
• Will focus on those I’ve bolded and italicized



You don’t HAVE to work in projects
• Available File tab (Window>Show View>File)
• Has full access to file system
• Also available FTP support (more on this later)• Also available FTP support (more on this later)
You CAN now open files from the OS
• And it doesn’t open entire new workbench
• http://www.carehart.org/blog/client/index.cfm/2009/7/28

/cfbuilder_tip_opening_files_from_outside_editor



Alternative ways to find/open file
• ctrl+shift+r or Navigate>Open Resource

lets you type name to find any matching
• Open CFC toolbar buttonOpen CFC toolbar button 

(2 to the right of “Print” button)
Similar to “open resource” but limits to display of CFCs

B h h h d f f• Both these presume chars typed are at front of 
filename/path

Can use * or ? In chars to do wildcards



Switch among open files
Ct l f6 ith t l b k d f th d• Ctrl+f6 either toggles back and forth among opened 
files or hold down ctrl to see list to choose from

• Ctrl+e opens list of editors, with just file names, not 
paths Can either mouse down and select or type letterspaths. Can either mouse down and select or type letters 
to filter and select

Ctrl+shift+e is slightly different and useful
• Common eclipse shortcut, shift+tab/ctrl+shift+tabCommon eclipse shortcut, shift+tab/ctrl+shift+tab

doesn’t work as expected
Switches between source and internal browsing

• Ctrl+pgup/dn moves among opened tabspg p/ g p
Alt+left/right moves among opened tabs, not obvious order

• Ctrl+q takes you back to last file being edited



For a file you open often, bookmark it
S l fil i i h• Select file in navigator, then Edit>Add Bookmark on 
main menu

• Can also bookmark lines within files, to open and 
j h lijump to that line

Finding currently open file in Project 
navigator treenavigator tree

Right-click and choose Show In>Navigator

To always sync navigator and opened file
I t i ht f N i t i li k t d iIn top right of Navigator view, click two-arrowed icon 
(Link with Editor)

Or click down arrow on its right and choose Link with Editor



Local history – poor man’s version control
• Eclipse keeps tracks of changes (made in IDE)
• Right-click text or file, Compare With>Local History
• How far back are changes saved?• How far back are changes saved?

Preferences>General>Workspace>Local History
Beware max file size setting, limits files tracked this 

away
Find/search across multiple files
• Ctrl+h or Search>SearchCtrl+h or Search>Search
• Can choose between entire workspace (all projects)

Or selected resource (if one is selected in navigator)



Quickly open included files, called CFCs, more
l h ( d h ) l k l k• Ctrl+hover (command+hover on Mac) + click on link

To open included file, invoked CFC/method/UDF 
Whether in tag or script or using “new” keyword
Can even jump to specific method

• Also html tags, like <script src=>
• Obviously won’t work for paths stored in variables
• Also won’t work even with hard-coded paths if outside 

relative path
If project is not connected to a Server or linked folders

Also, if it doesn’t work at all, try closing and reopening file
• More info

http://blogs.adobe.com/cfbuilder/2009/07/code_hyperlinking.html



Split window
• Use Window>New Editor
• Can then right-click on tab to move to be 

above/below, side by sideabove/below, side by side
Turning on word wrap
• Preferences>HTML>Editors (no need to expand)

Then click Advanced tab
and click on Enable word wrap option

• Also an available pluginAlso an available plugin
http://blogs.adobe.com/cfbuilder/2009/08/enable_w
ord_wrap.html



Turning on line numbers
• Right click on gutter “show numbers” or• Right-click on gutter, show numbers …or…
• Preferences>general>editors>text editors
Wish tab would insert spaces instead?
• Preferences>General>Editors>Text Editors (don’t expand)• Preferences>General>Editors>Text Editors (don t expand)

Click Insert spaces for tabs
• Preferences>HTML>Editors (don’t expand)

Choose Tab Insertion, Use Tabs/Use Spacesp
Filter feature, in Preferences dialogue
• Also useful in many other places in IDE
Creating new blank page, without file nameg p g
• File>New>Other>Untitled Files>Untitled HTML File
• Note that to use CFML editing features, must close and 

reopen as CFML editor



Be sure to explore (all in docs, and some blogs)
• Refactoring• Refactoring

http://blogs.adobe.com/cfbuilder/2009/07/refactoring_in_c
oldfusion_buil.html

• Snippets. Two places:Snippets. Two places:
Window>Show View>Other>HTML Standard Views>Snippets
Window>Show View>Snippets (CF Snippets, with trigger text, 
launched with ctrl+j) 
Sharing them:

http://blogs.adobe.com/cfbuilder/2009/08/use_your_snippe
ts_across_ides.html
http //blog m nit org/2009/12/sharing o r cfeclipsehttp://blog.mxunit.org/2009/12/sharing-your-cfeclipse-
coldfusion.html

• Outline view (Windows>Show View>Outline)



As well as these (discussed in docs)
• Content assist in many places

http://blogs.adobe.com/cfbuilder/2009/07/content_assist_tips.html
Discussed as both code assist and smart assist in docs
Note available Ctrl+space to request assist anytime

• Code folding
Equivalent of code collapse in DW HS+Equivalent of code collapse in DW, HS+

• Editing more than just CFML
• And much more, discussed in docs, other resources



Code assist is quite configurable
• When, when not to assist, how fast, colors, shortcuts, etc
• See Docs, “Code Assist” chapter:

http://help.adobe.com/en_US/ColdFusionBuilder/Using/WS0
ef8c004658c1089-554789f8121af8f0c8c-7ffb.html

Keyboard shortcuts configurability: 2 kinds
• Preferences>ColdFusion>Editor Profiles>Editor>KeysPreferences>ColdFusion>Editor Profiles>Editor>Keys
• Preferences>General>Keys
• Also, CFB may overtake keys familiar in Eclipse/CFEclipse 

(ctrl+3 ctrl+shift+L ctrl+j)(ctrl+3, ctrl+shift+L, ctrl+j)
Remember filter feature—can type name of keystroke (like 
“shift+f2”) in General>Keys to find assignment and change



Critical: finding that CFB doesn’t create closing 
tags when/how you prefer?tags when/how you prefer?
• Preferences>ColdFusion>Editor Profiles>Editor>Typing

Can control what chars auto-close (quotes, brackets, #’s)
Can control Auto-close Tags just as Dreamweaver allowed:g j

When typing  ‘> of start tag
When typing  ‘</’ of end tag
Never (curiously, this is default)

Leads nicely to available “editing profiles”Leads nicely to available editing profiles
• Can choose between Default, Eclipse, Dreamweaver
• Preferences>ColdFusion>Editor Profiles
• Can control Code Assist Colors Keys Syntax checking• Can control Code Assist, Colors, Keys, Syntax checking, 

Typing, Outline
• More in docs and at http://sandeepp.org/blog/?p=113



Configurable CFML dictionaries
• For different versions of CF, different CFML engines
• See Preferences>ColdFusion>Editor Profiles>Editor>Code 

AssistAssist
• See docs, “Code Assist” chapter
• In future, may be more easily customizable
“Recently opened files” setting
• Preferences>General>Editors then Size of recently opened files list



Setting URL Prefix for internal browsing
• Those who don’t care for defining a CF Server in 

CFB may miss being able to browse internally
• Beta 2 added URL Prefix option for browsing, etcBeta 2 added URL Prefix option for browsing, etc

Without needing to have defined a server and linked 
your project to a server

• Can now right click project/folder in S t URL P fi• Can now right-click project/folder in , Set URL Prefix
• Applies also to debugging
• To browse internally, use Ctrl+tab/Ctrl+shift+tab

http://blogs.adobe.com/cfbuilder/2009/07/previewin
g_a_file_in_123_steps.html



Look into other useful Eclipse-specific 
features for configuring the IDE
• Fast Views
• Detached Views• Detached Views
• Moving, maximizing, resizing views

Just remember that you can adjust them
• Can customize, save new perspectives
• Can restore/reset perspective if it gets messy
Certainly much more but need to move onCertainly much more, but need to move on



Problems with memory? What are 3 tips?
Can view current memory use by CFB (and 
can request GC within it)

P f G l th li k Sh  h  • Preferences>General then click Show heap status

Close projects if you’re not using them
Can (perhaps should) increase default heapCan (perhaps should) increase default heap 
size
• Especially if running w/ FlashBuilder, other plugins
• http://www.adrocknaphobia.com/post.cfm/update-your-

coldfusion-builder-beta-settings-for-flash-builder-4-beta



Wondering why things are slow? Find out!
• Some may know common Eclipse troubleshooting views• Some may know common Eclipse troubleshooting views 
• Window>show view>

Console – shows various Eclipse operations
Problems – shows syntax errors in code, and more
Server – shows what’s going with CF server processing
Other>General>Error Log – shows errors with IDE itself

• But many may miss the most important view!
Other>General>Progress - shows background processing (indexingOther>General>Progress shows background processing (indexing 
of CFCs, FTP operations, much more)

CFB may seem slow at startup, due to “building server 
settings”

M ti i P i• May see operations in Progress view:
“indexing CFCs of server xxx”, “indexing files from webroot”
Can change to NOT do this during startup using 
Preferences>ColdFusion>Server Settingsg



Try creating a new workspace 
Fil S i h W k• File>Switch Workspace

• If things aren’t working as expected, and you’ve used 
previous versions of CFBuilder or Eclipse

Try starting CFBuilder (or Eclipse) with the cleanTry starting CFBuilder (or Eclipse) with the –clean 
argument
• Yes, this and other Eclipse.exe command-line arguments 

b d ith fb ildcan be used with cfbuilder.exe
• Note also –perspective arg to open a given perspective

See 
http://www carehart org/blog/client/index cfm/2010/6/18/http://www.carehart.org/blog/client/index.cfm/2010/6/18/
cfbuilder_flashbuilder_command_line_perspective_specificati
on



Also note available Workbench error log 
• may help understand some problems• may help understand some problems
• Help>Product Details>Configuration Details>View error log

(opens log in browser window)
On OS X, it’s under Adobe ColdFusion Builder>About Adobe 
ColdFusion Builder>Configuration Details>View error log
(Indeed, in older Windows versions, it was at Help>About 
ColdFusion Builder>Configuration Details>View error log )

Adobe is also now recommending obtaining aAdobe is also now recommending obtaining a  
stack trace (using a given tool) for knotty 
problems
• http://blogs.adobe.com/cfbuilder/2009/10/cfbuildercfbp // g / / / /

_performance.html
• http://forums.adobe.com/message/2328981#2328981



“Things to watch out for while installing CFB”
h //bl d b / fb ild /2010/03/ hi• http://blogs.adobe.com/cfbuilder/2010/03/things
_to_watch_out_while_inst.html

Mac users may find that…  y
• Time Machine is the culprit

Not saying “don’t use it”, but find if it’s the issue and 
report details to Adobep
For more thoughts, see 

http://blogs.adobe.com/cfbuilder/2009/10/issues_on_m
ac_-_some_tips.html 

• CFB Internal Firefox conflict
http://blogs.adobe.com/cfbuilder/2009/11/cfb_perfor
mance_on_mac_-_how_i.html



Option to configure “Server” for Project
• No time to get into all the challenges of connecting 

to servers, local or remote
Benefits are FAR more than just starting/stoppingBenefits are FAR more than just starting/stopping

• See CFBuilder docs for much more (important) 
explanation

S l Ad b T bl t iSee also Adobe Team blog entries
http://blogs.adobe.com/cfbuilder/2009/09/what_does_not_work_in_content.h
tml
http://blogs.adobe.com/cfbuilder/2009/07/server_manager.html
http://blogs.adobe.com/cfbuilder/2009/07/remote_server_setup_is_it_real.html
http://blogs.adobe.com/cfbuilder/2009/07/remote_server_setup_-_multiser.html
http://blogs.adobe.com/cfbuilder/2009/08/importing_rds_server.html



Beta 2 added important changes for Server 
config (see docs)
• Adds virtual Host support

Can configure server settings to use web server virtualCan configure server settings to use web server virtual 
hosts
Applies to browsing, debugging, code assist, more

Add t f JR• Adds support for non-JRun servers
Can now point to other than JRun (JBOSS, WAS etc) 
when configuring server settings

Can't start-stop-restart the server, but do get other 
benefits (recall previous page)

• Adds various other bug fixes for server connection



Yes, CFBuilder supports FTP (and SFTP/FTPS)
• and no, you don’t NEED to use Projects
For projects, can set during project creation 

or in project properties (right clicking file/text in• or in project properties (right-clicking file/text in 
project

Can also do without projects, in Files viewp j ,
• Right-click to edit text or file or folder, choose 

Synchronize>Create New Synchronize Connection
But wait there’s more (I know some willBut wait, there’s more (I know some will 
wonder something)…



If using File tab with file opened from FTP server, 
yes a save will save to the remoteyes, a save will save to the remote
If using Navigator tab with file opened from local
• Save does not save to remote
• But there is an available shortcut to upload

Right-click on text, Synchronize>Upload

There are also options to sync many files at oncep y y
• Right-click on text, Synchronize>Synchronize
• Or available Sync Explorer view (don’t miss!)

Window>Show View>Other>HTML Standard Views>Sync Explorery p
• Note that “Team Synchronize” is instead about CVS
How to Edit FTP server configurations

Window>Show View>Other>HTML Standard Views>Sync Managery g



Don’t miss available web services browser
In Wi d Sh  Vi S i  B view• In Window>Show View>Services Browser view

• Allows browsing, building of code to call web svcs
• Not much doc at all. See:

http://www.carehart.org/blog/client/index.cfm/2009/8/7/cfbuilder browsing web serviceshttp://www.carehart.org/blog/client/index.cfm/2009/8/7/cfbuilder_browsing_web_services

Linked folders (outside of project location)
• See doc section, and:
• http://blogs.adobe.com/cfbuilder/2009/08/link_folders.htmlp g
More about CFML debugging
• See CFB docs and:
• http://blogs.adobe.com/cfbuilder/2009/07/debugging_in_cfbuilder.html
• See my presentations on CF step debugging

http://www.carehart.org/presentations/



Can turn off splash screen in
Preferences>ColdFusion>StartupPreferences>ColdFusion>Startup
To do find/replace within file, use Edit>Find, 
(ctrl+f) not Search>Search (ctrl+h)
• The former does just within file operations• The former does just within file operations
• The latter does cross-file/project operations

Warning: people used to using ctrl+h to do file find/replace 
from other tools may inadvertently do replace across entire 

k O h!workspace. Ouch!
• If doing Search>Search, note that using “*.*” for search 

of all filenames/filetypes will not work. Must use just “*”
Apply cfnature to projectApply cfnature to project
• http://blogs.adobe.com/cfbuilder/2009/07/apply_cf_na

ture.html



Tailview view has option to color-code logs
• Window>Show View>TailView• Window>Show View>TailView
• Use “color settings” properties (top right of view)
• Can assign color to string, regex
• Can export/import to share with othersCan export/import to share with others
Beta 2 also added… 
• SQL editor

While inside CFQUERY, right-click and choose SQL Editor or Q , g Q
use Ctrl+alt+s

• Context-sensitive CFML help (F1 on tag, function)
Didn’t seem to work on Mac for me, though

Also help opened in Mac can’t be copy/pastedAlso, help opened in Mac can t be copy/pasted.
Workaround: http://onflash.org/ted/2007/08/flex-builder-
tip-preferences-general.php

• See docs for more on each



Beta 3 added… 
• Standalone deploys on Eclipse 3 5 1 (Galileo)• Standalone deploys on Eclipse 3.5.1 (Galileo)
• Code Assist for ColdFusion ORM

Provides Code Assist for many ColdFusion ORM settings
See “Code Assist for ColdFusion ORM” in Using Adobe CF BuilderSee Code Assist for ColdFusion ORM  in Using Adobe CF Builder

• Enhanced SQL Editor
Now lets you execute SQL statements and display the results 
within the SQL Editor

See “Using SQL Editor” in Using Adobe CF Builder
• Extensions view

Use to install, uninstall, import, and reload extensions
See “Using the Extensions view” in Using Adobe CF BuilderSee Using the Extensions view  in Using Adobe CF Builder

• Support for Ext/JS 3.0 libraries
Can now import Ext/JS 3.0 libraries with samples

See “Import Ajax libraries” in Using Adobe CF Builderp j g



Beta 3 also added… 
• AIR application development• AIR application development

Can create projects, run or debug, package, and sign the AIR 
application

See “Developing AIR applications” in Using Adobe CF Builder
Gotcha: http://www 12robots com/index cfm/2010/7/28/EnablingGotcha: http://www.12robots.com/index.cfm/2010/7/28/Enabling-
Access-to-the-Adobe-AIR-Tools-in-ColdFusion-Builder

• Optimizing ColdFusion Builder performance
Preference options affect the performance of CF Builder
For faster editor performance can apply preset editorFor faster editor performance, can apply preset editor 
preferences

See “Optimizing ColdFusion Builder performance” in Using Adobe CF 
Builder

• ColdFusion Builder Help system• ColdFusion Builder Help system
Now uses Adobe Community Help Client - Adobe's next-
generation Help experience. An AIR app.

See “ColdFusion Builder Help System” in Using Adobe CF Builder



Many other useful Eclipse features to investigate
• Linked resources (as opposed to Linked Folders)• Linked resources (as opposed to Linked Folders)

Preferences>General>Workspace>Linked Resources
• Can compare files to each other 

select them then and right-click and choose Compare withselect them, then and right click and choose Compare with

• Can get net-based features working if behind firewall/proxy
See Preferences>General>Network Connections

• Incremental find (Edit>Incremental Find Next)( )
• Piano Keys Feature (alternating shaded/white lines in editor)
• File>New>Other>HTML Projects>Existing Hosted Site
• Tasks – can add tasks for file, line, or not associated with anything
Many available additional plug-ins for Eclipse
• Version control, database integration, lots more



To hide/show carriage return and other 
unusual (“hidden”) characters suddenly 
appear, toggle ctrl+. (that’s a period)
Features lost when editing file not in a projectFeatures lost when editing file not in a project
• (Meaning: files opened using files tab, not 

navigator)g
• Local history
• Recent files list
• Perhaps more• Perhaps more



This has not been the ultimate list
• We have only 50 minutes
• We have different audiences
• We have different tools under the covers

Eclipse, Aptana, CFBuilder
• Goal certainly wasn’t to show all, or even most, features
You can find many more tips and hidden gemsYou can find many more tips and hidden gems
• Besides CFB docs, many resources available on Eclipse, 

Aptana
C l h f thCan learn much from those

• Can even learn from CFEclipse resources
Just beware some CFE-specific things were not ported



CFBuilder Installation Guide
• http://help.adobe.com/en US/ColdFusionBuilder/Installing/index.htmlhttp://help.adobe.com/en_US/ColdFusionBuilder/Installing/index.html
CFBuilder User Guide
• http://help.adobe.com/en_US/ColdFusionBuilder/Using/index.html
CFBuilder Forum/List

http://forums adobe com/community/coldfusion/coldfusionbuilder• http://forums.adobe.com/community/coldfusion/coldfusionbuilder
CFBuilder Adobe Team Blog
• http://blogs.adobe.com/cfbuilder/
CFBuilder Bug Trackerg
• http://cfbugs.adobe.com/bugreport/flexbugui/cfbugtracker/main.html
Akbarsait’s list of CFBuilder tutorials and resources
• http://www.akbarsait.com/cfbuildertutorials.cfm
Others have done talks on CFBuilder recording linksOthers have done talks on CFBuilder, recording links 
offered  at http://www.carehart.org/ugtv/



Eclipse, Eclipse Getting Started resources
htt // li• http://www.eclipse.org

• http://www.eclipse.org/resources/?category=Getting%20Started
See especially Basic Tutorial to learn Eclipse

Eclipse Tips and TricksEclipse Tips and Tricks
• Help>Help  Contents>Workbench User Guide>Tips and Tricks
Aptana Studio resources
• http://www.aptana.org/
I may develop more resources
• More detailed discussions as blog entries g

(carehart.org/blog)
• May also develop half-day class on CFB gems
• And/or daylong class on Intro to CFB



For learning purposes only 
• not for production purposes
Includes all qualified students, faculty and 
staff of eligible education institutionsstaff of eligible education institutions
More at:
• https://freeriatools.adobe.com/cfbuilder/https://freeriatools.adobe.com/cfbuilder/



Hope everyone here has learned at least some 
new gem
• Remember, we have different audiences here
• Is there anyone who didn’t learn a single thing new?• Is there anyone who didn t learn a single thing new?



Charlie Arehart
• charlie@carehart.org
I’d really appreciate your feedback

http://carehart org/feedback/• http://carehart.org/feedback/
Available for ColdFusion troubleshooting
• Remote or on-siteRemote or on site
• No time minimum, satisfaction guarantee
• http://carehart.org/consulting/
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