Hidden Gems in ColdFusion Builder 2

Charlie Arehart
charlie@carehart.org
Twitter comments welcome: @carehart

Last updated: 6/17/2011
About the presentation

- As last year, not an “Intro to CFBuilder”
  - There are many important features I won’t discuss
- Nor is it “all that is new in CFB2”
- Still, many, many tips to share
  - Will often point to URL with more info
- I also have many more in last year’s CFB talk
- Both presentation PDFs posted at carehart.org/presentations
Audience

- Consider that it may include those:
  - new to—or expert in—either:
    - CFBuilder 1, CFB2, Eclipse, CFEclipse, other editors

- Please be patient
  - You may already know some of these things
  - You may even think of things I didn’t share
  - A few things will apply to CFB1 as well
  - Feedback welcome, as always
Session Outline

- Hidden Gems in Installing
- Hidden Gems in Configuring
- Hidden Gems in CFB2
  - Coding Features
  - Shortcuts
  - Searching
  - Miscellaneous
- Resources for Learning More
About Charlie Arehart

Independent Consultant
• 13 yrs CF experience (27 in Enterprise IT)
• Member, Adobe Community Professionals
• Certified Adv CF Developer (4–8), Cert. Adobe Instructor
• Frequent speaker to user groups, conferences worldwide
• Run the 2500–member Online ColdFusion Meetup (coldfusionmeetup.com)
• Living in Alpharetta, Georgia (Atlanta)

Web home at www.carehart.org
• Host ~300 blog entries, 80+ articles, 90+ presentations
• UDTV: recordings of 500+ presentations by ~250 speakers
• CF411.com – 1,200+ tools/resources in 125+ categories
• CF911.com – coming soon
• Hosting courtesy of EdgeWeb Hosting
• Consulting: available for CF troubleshooting, tuning; training
  • Remote or on–site
When I refer in talk to CFBuilder Preferences
- it’s in Window>Preferences on Windows and Mac (as of CFB2 Standalone)
  - but in Adobe ColdFusion Builder>Preferences on Mac as plugin
- I’ll just start with Preferences> to avoid confusion
  - But note that Window menu option does exist on Mac, used for other things, like Window>Show View

And of course, if I say ctrl-click something, on Mac that’s command-click

That said, this is not a “shortcuts talk”, though many will be shared, given CFB’s nature
- Mouse equivalents offered where available

OK, on with the gems…
Hidden Gems in *Installing*

- Don't miss the documentation:
  - Installation guide (11 pages)
  - User guide (123 pages)
  - Release notes (9 pages)
    - especially "getting started" section
- Find all docs on Adobe site
  - And via [http://cfdocyard.blogspot.com](http://cfdocyard.blogspot.com)
    - [http://tinyurl.com/cfb2docyard](http://tinyurl.com/cfb2docyard)
Hidden Gems in Installing (cont.)

- You **can** install CFB2 alongside CFB1 (standalone)
  - Any beta of CFB2 must be uninstalled
- You **can** use the same workspace for both
  - But should use “clean” option on startup
    - See last section of CFB2 Install Guide, “Clean and reinitialize workspace”
- Other integration issues:
  - Cannot install CFB1 and 2 as plug-ins with the same Eclipse installation
  - Can install CFB2 as a plug-in with Flash Builder 4.5
    - CFB2 cannot be installed as plug-in within Flash Builder 4
Hidden Gems in Installing (cont.)

- Not new, but did you know…?
- Single license can be used on up to two computers (even across operating systems)
- To move license beyond first two, must deactivate on one
  - Use Help > Adobe ColdFusion Builder Deactivation
  - Discussed in both CFB1 and 2 user guides
Hidden Gems in Installing (cont.)

- Regarding "admin server" components offered during installation...
- To be installed on server running CF (if not same as dev workstation)
- Needed only if interested in starting/Stopping CF from within CFBuilder
  - further, only needed on CF 7 or 8 (already in CF9)
- ...

Charlie Arehart | charlie@carehart.org | www.carehart.org | @carehart
More on "admin server" components…
Do then need to start the admin instance manually (not set to start as a service)
  • also, note this is NOT the same admin instance as available in Multiserver deployments of CF
Also, may need to update security properties for the remote ColdFusion server
  • `{CFHome}/runtime/lib/security.properties` entry for `jrun.subnet.restriction` and `jrun.trusted.hosts`
  • May also need to open firewall hole for JNDI port
See Installing CFBuilder manual for more on all these install matters
Hidden Gems in Configuring

- **Use projects or not?**
  - While you don't NEED to use CFB with projects
    - Note that some features only work in files that are opened within a project

- **Configure servers or not?**
  - Similarly, while you don't NEED to configure a server connection in CFB
    - some features only work in files that are opened within a project that is connected to a server

- …
If you connect a CFB project to a server and make mistake, some feature may fail silently

Note:
- I offer CFB troubleshooting assistance
  - low fixed price
- (Can't communicate here all that could go wrong)

Helpful related blog entry: "Where ColdFusion Builder finds my CFCs?"
Hidden Gems in **CFB2 Coding Features**

- Again, not “what all is new” in CFB2
  - More about gems within these new features
  - “You have heard it said…”

- **Code Assist**
  - Tag/functions pop up while typing
    - Change from CFB1, had to press *ctrl-space*
  - Applies also to attributes/values, arguments, vars/scopes
    - can press *ctrl-space* if/where needed to force assist
  - Shows dependent attributes only: nice

- Gems?...
Hidden Gems in *CFB2 Coding Features* (cont.)

- Code Assist gems...
- “Filter” feature in Code Assist
  - If you type part of attribute, function, var, or scope
    - It will show only those matching that (using ctrl-space shortcut)
- Shows only vars that could work
  - Such as struct vars in struct function
- Cycling through code assist
  - Repeat the ctrl-space shortcut
  - Cycles showing vars and scopes→functions→both
Hidden Gems in **CFB2 Coding Features** (cont.)

- Code Assist gems (cont.)…
- Control for these code assist features
  - `preferences>coldfusion>profiles>editor>code assist`
- See also video at
Hidden Gems in **CFB2 Coding Features** (cont.)

- Code folding gems:
  - CFB2 remembers folding across close/open of file
- CFB2 lets you fold arbitrary code
  - Select code and use *ctrl–alt–f*
  - CFB1/2 let you fold nesting tags by clicking + in gutter
  - Mouse equivalent: right–click and choose `source>toggle folding at selection`
  - Trap: after uncollapsing abritrary code, a – will remain in gutter
    - To remove, use keyboard or menu cmd on first line that was abitrarily collapsed (showing – in gutter)
Hidden Gems in **CFB2 Coding Features** (cont.)

- Code navigation/tag selection gems:
  - You may have heard *Ctrl–alt–b* selects enclosing tag (or script)
    - gem: repeat keystroke to keep selecting next enclosing tag/script
  - *Ctrl–alt–m* jumps to matching tag/script (when cursor is on start or end tag/script)
    - trap: if keystrokes don't work, beware that some other app may be overriding
    - for instance, this *ctrl–alt–m* doesn't work for me
      - but *ctrl–alt–n* opens new note in evernote
        - so something else could be intercepting the “m”
Hidden Gems in **CFB2 Coding Features** (cont.)

- Code navigation/tag selection gems (cont):
  - `ctrl-shift-up/down arrow`
    - moves among functions (whether tags or script, in cfm or cfc files)
    - also moves among cfif/cfswitch lines, if the focus is on one to start with
    - Trap: `ctrl-alt-up/down` instead duplicates line
  - `ctrl-]/[`  
    - moves among attribute values in a tag or script statement, or among args in a function call
  - See later discussion of shortcuts for how to see/change all these shortcuts
Hidden Gems in **CFB2 Coding Features** (cont.)

- Hover help gems:
- When you mouse over a tag or function, a small window pops up some basic info on that:
  - Gem: for a user-defined function or method, shows any defined hint
- Trap: only works for files opened as project
- Trap: and will only be able to find hint for methods in other than current file if the project is connected to a server
- Trap: and if you update something like a cfc hint, while CFB is open, seeking the hover help on a calling page will not detect change:
  - Don't need to restart CFB. Just need to refresh server
Hidden Gems in **CFB2 Coding Features** (cont.)

- “Quick Fix” gems:
  - Cool feature
  - offers to create functions/cfcs/cfc methods when first referenced
    - Click icon in gutter, or right-click and “quick fix”
  - Gem: can also use `ctrl-1` to initiate
  - Gem: if call to function or CFC is in cfscript
    - CFB will create new function/cfc in script syntax

- **video:**

- ...
Hidden Gems in *CFB2 Coding Features* (cont.)

- “Quick Fix” traps:
  - Trap: won't work unless file is opened within a project
  - Trap: can’t work if using vars for cfc path
  - Trap/bug: if cfc to which a method is being added to is opened in browse mode within CFB
    - The function will be added within the caller instead
  - See release notes for some other "known issues"
Hidden Gems in **CFB2 Coding Features** (cont.)

- **Tag completion trap/gem:**
  - **Trap:** CFB2 STILL does not auto-close tags while typing
    - You must turn it on
      - Preferences>ColdFusion>Profiles>Editor>Typing
  - **Gem:**
    - Code assist tag insertion DOES create closing tag by default
      - Controllable separately in
        - Preferences>ColdFusion>Profiles>Editor>Code Assist
Hidden Gems in **CFB2 Coding Features** (cont.)

- Code Formatting gems:
  - You’ve heard that you can reformat code using `ctrl-shift-f` (or right-click and *format*)
    - Or with mouse using *Edit > Format*
  - Gems:
    - Can also apply to a selection of code
    - Can be undone (if in whole or in part)
    - Works for CFML as well as other content (html, javascript, css)
Hidden Gems in **CFB2 Coding Features** (cont.)

- Code Formatting gems (cont):
  - Gem: yes, you can customize the way formatting happens
    - Preferences>ColdFusion>Profiles>Editor>Formatter
  - Note option to select "profile"
    - By default there is only one (which cannot be edited)
    - But can easily add/edit a new one
      - will become default
  - …
Hidden Gems in **CFB2 Coding Features** (cont.)

- Code Formatting gems (cont):
  - Note many options, to control:
    - whether tags/attributes are upper/lower case, whether to add closing slash to single tags
    - whether to use tab or space for indentation, size, what tags NOT to indent
    - LOTS about handling whitespace, including where to use add spaces or blank lines under MANY circumstances
    - whether to wrap attributes, arguments, and much more on a line; if so, how many or how wide at most
    - where braces are in script (same line, next line) for function, if, switch, try, and more
  - Note also available preview feature
  - Trap: note a couple of "known issues" in the release notes
Hidden Gems in **CFB2 Shortcuts**

- Various aspects related to shortcut keys...
- **Not new:**
  - Perhaps easiest shortcut for moving among files
    - `ctrl-pgup/pgdn` (or `ctrl-shift/alt-pgup/pgdn`)
    - But not `alt-pgup/pgdn` or `ctrl-tab`, which do internal browse
- **CFB1** also had various shortcuts to enter commonly used tags
  - like `ctrl-shift-d` to insert `cfdump`, `ctrl-shift-m` to insert `cfml` comment
- **CFB2** uses different shortcut
  - `ctrl-t` then `d`, or `ctrl-t` then `m` respectively
- ...
Hidden Gems in **CFB2 Shortcuts**
(cont.)

- **Ctrl–t** now shows list of shortcuts
  - to enter certain common tags (for inserting text)
  - Or with mouse, right-click and *Source*

- Trap: in cfb1, **ctrl–t** called up a tag editor
  - that is now **ctrl–shift–t** in cfb2
Hidden Gems in **CFB2 Shortcuts** (cont.)

- To see all/other CF shortcuts
  - see Preferences>ColdFusion>Profiles>Keys
  - Gem: note there's some logic to grouping of keystrokes, some are multi-keystroke
    - Insert shortcuts start with $CTRL-T$
    - Wizards shortcuts with $CTRL-ALT-W$
    - Extensions shortcuts with $CTRL-SHIFT-E$

- Trap: Curious that those second two use alt and shift
  - while first uses no 2nd keystroke
Hidden Gems in *CFB2 Shortcuts* (cont.)

- Can now export/import CF shortcuts
  - From that preferences page
  - Trap: need to scroll down on page to export/import buttons
- As before, prefs page also lists all CF shortcuts
  - Gem: many more shortcuts to insert things than before
  - and now more than just tags,
  - adding new server, extension, project, file, and more
- As before, prefs page shows only CF shortcuts
  - Separate list of keys for all of eclipse
    - *Preferences>*general>*keys*
Hidden Gems in CFB2 Shortcuts (cont.)

- Gem: in CFB2, you can now specify "insert text" in a newly created shortcut
  • will appear between tags
- Gem: if you need to enter text and also set a cursor position, use $$\{CP\}$$, as in:
  • <cfsometag someattributes>$$\{CP\}$$</cfendtag>
Hidden Gems in *CFB2 Searching*

- You may have heard about ability to search for tags/attributes…
- Gem: many ways to control where to search
  - Current document
  - Open documents
  - Project(s) (selectable)
  - Local directory
  - FTP location
  - RDS location
  - Workspace or working set
- …
Hidden Gems in *CFB2 Searching* (cont.)

- Gem: can select text and launch find
  - that code will be used for the search string
  - or you can change the search string and now only that selected code will be searched

- Gem: “incremental search” checkbox
  - Searches while you type (within current doc)

- ...
Hidden Gems in *CFB2 Searching*
(cont.)

- Can also do find or replace
  - can do one or all occurrences (of find and replace)
- Gem: when doing replace using tag search, check out available "action". Can:
  - remove the tag block
  - change a given attribute to a given value
  - remove an attribute
  - add something before/after the tag (such as a standard comment before a function definition)
- More info in docs
Hidden Gems in *CFB2 Searching* (cont.)

- For tag search across multiple files
  - can set to be all files, all cfm, all cfc, both, more
- Trap: when doing replace across multiple files
  - It’s supposed to show preview feature
  - But I did not find this to be true, regardless of the "location"
Hidden Gems in **CFB2 Searching** (cont.)

- Of course, some hate this took over Eclipse find feature
  - Still there as *Search > File*
  - You should be able to swap the shortcuts, as discussed above

- Comparison of Eclipse and CF search features

- Some key additions in CF Search:
  - tag search, search of open documents, search across RDS/FTP, multi-line search, ignore whitespace, and more
Hidden Gems in *CFB2 Searching* (cont.)

- Tag-based search:
  - Very powerful, yet easy
    - Will be familiar to those coming from DW (at least, if they noticed it offered there)
  - Use Ctrl-F (or *Search>ColdFusion Search*), then change Search drop-down from Text to Tag
    - You can choose any tag, and choose to search for its occurrence with any attributes or values (or not having them occur)
    - And if doing a replace, can add/change/delete attribute/value
  - Really far more powerful than “just a text search”
    - So beware, it will take a little longer, parsing lines
**Miscellaneous Hidden Gems in CFB2**

- **Start page (in project definition):**
  - Useful for front-controller apps
  - Can set the file to use to launch when previewing, browsing (from within CFB), or debugging a project

- **Can create CFM files from file (not project) navigator:**
  - In File view, right-click any local folder
  - Then select New>ColdFusion Page (or Component or Interface)
Highlights from my CFB1 Gems talk

- That talk covered much more, including:
  - Hidden Gems in Working with Files
  - Hidden Gems in Editing
  - Hidden Gems in Configuring the IDE
  - Hidden Gems in Troubleshooting
  - Hidden Gems in Connecting to CF Servers
  - Hidden Gems in Editing Code on Remote Servers
  - Miscellaneous Hidden Gems
  - Some Gotchas
Definitely far more gems you can find

- This has not been the ultimate list
  - We have only 50 minutes
  - We have different audiences
  - Goal certainly wasn’t to show all, or even most, features

- You can find many more tips and hidden gems
  - Besides CFB docs, many resources available on Eclipse, Aptana
    - Can learn much from those
CFBuilder Resources

- CFBuilder 2 User Guide

- CFBuilder 2 Installation Guide

- CFBuilder 2 Release Notes:
  - Note especially “known issues”
    - Some oddities that happen one time
    - As well as issues with using CFB as plugin, or along with FB
CFBuilder Resources (cont.)

- CFBuilder Forum/List
- Adobe CFBuilder Team Blog
- CFBuilder Bug Tracker
- Akbarsait’s list of CFBuilder tutorials and resources
  - http://www.akbarsait.com/cfbuildertutorials.cfm
- Others have done talks on CFBuilder, recording links offered at http://www.carehart.org/ugtv/
Some other blog entries

- Tag coloring:
  - Changing tag colors
    - http://sandeep.org/blog/?p=130
  - Changing comment colors
    - http://sandeep.org/blog/?p=84
  - See also release notes for some other "known issues"

- File encoding (utf-8/) support
  - http://sandeep.org/blog/?p=159

- Create snippets from cflib

- CPU spike if TailView is kept open in CFBuilder
  - http://blogs.adobe.com/cfbuilder/2010/05/cpu_spike_if_tailview_is_kept.html
That’s it

- Hope everyone here has learned at least something
  - And hopefully a few new things!
Questions On Presentation

- Charlie Arehart
  - charlie@carehart.org
  - I’d really appreciate your feedback
    - http://carehart.org/feedback/
  - Available for ColdFusion and CFBuilder troubleshooting
    - Remote or on-site
    - No time minimum, satisfaction guarantee
    - Also available “CFBuilder fixed fee solution for one problem”, up to a max of 2 hours
    - http://carehart.org/consulting/